I broke my pump impeller

Experiencing technical problems? Look here for help!

Re: I broke my pump impeller

Unread postby Dicko » Sun Dec 21, 2014 9:27 pm

Oz11 wrote:I've a BM 20L I bought in the UK in June of this year and it has a "Lowara" pump... nothing about ITT on it though :?


Yes Oz11 I see that this is a problem as I believe that Speidel have used many different brands of pump on their products and there is no information available that I can find regarding the parts for the different models.

I wonder if we approached Speidel that they would give us a list of part numbers??

:cheers:
The worst thing that can happen if I die is that my wife will sell all my brewing equipment for what I told her I paid for it
User avatar
Dicko
 
Posts: 1179
Joined: Tue Jan 21, 2014 8:25 pm
Location: Port Lincoln South Oz
Model: 20 litres

Re: I broke my pump impeller

Unread postby zoigl » Sun Dec 21, 2014 11:15 pm

Hi Dicko
I broke my impeller exactly the same way. Ralph at Speidel posted me one from Germany a very long time back. I believe that a couple of different pumps exist, maybe Speidels can help with identification. I can't see what harm can be done using it as is until a replacement turns up. what can get further damaged? It is in a SS housing.
Give a man a beer, waste an hour. Teach a man to brew, and waste a lifetime!
User avatar
zoigl
 
Posts: 32
Joined: Tue Jan 21, 2014 9:28 pm
Location: Lawrence, NSW.
Model: 50 litres

Re: I broke my pump impeller

Unread postby Dicko » Mon Dec 22, 2014 12:25 am

zoigl wrote:Hi Dicko
I broke my impeller exactly the same way. Ralph at Speidel posted me one from Germany a very long time back. I believe that a couple of different pumps exist, maybe Speidels can help with identification. I can't see what harm can be done using it as is until a replacement turns up. what can get further damaged? It is in a SS housing.


G'day zoigl

I have had a talk to Chris at Grain and Grape and he advises me that there are two impellers for the 20 and the 50 models.
The way that they identify them is the description that one type is all black in colour and the other is black and stainless.
Mine is the all black one and G&G carry both in stock which I am pleased about.

I have ordered one from them and they are posting it today, can't beat that for service. $55.00 + postage :shock:

For any ones info here is a LINK

:cheers:
The worst thing that can happen if I die is that my wife will sell all my brewing equipment for what I told her I paid for it
User avatar
Dicko
 
Posts: 1179
Joined: Tue Jan 21, 2014 8:25 pm
Location: Port Lincoln South Oz
Model: 20 litres

Re: I broke my pump impeller

Unread postby Dicko » Sat Dec 27, 2014 12:39 am

zoigl wrote:Hi Dicko

I broke my impeller exactly the same way.

I can't see what harm can be done using it as is until a replacement turns up. what can get further damaged? It is in a SS housing.


OK, so my impeller didn't arrive before Xmas and I wanted to brew yesterday so I used the broken impeller.

I had a grain bill of 6kg in the 20 BM and it worked without fault....no noise...no vibration...just clean clear wort.

I can't wait to taste my "Broken Impeller IPA" :lol: :lol:

:cheers:
The worst thing that can happen if I die is that my wife will sell all my brewing equipment for what I told her I paid for it
User avatar
Dicko
 
Posts: 1179
Joined: Tue Jan 21, 2014 8:25 pm
Location: Port Lincoln South Oz
Model: 20 litres

Re: I broke my pump impeller

Unread postby Batz » Sat Dec 27, 2014 9:46 am

I need a holiday in Queensland :D :D


Your welcome here mate.
Pull up the van anytime.
Your not a real brewer until you own a Braumeister
User avatar
Batz
 
Posts: 313
Joined: Tue Jan 21, 2014 9:42 pm
Location: Queensland Australia
Model: 50 litres

Re: I broke my pump impeller

Unread postby Dicko » Sat Dec 27, 2014 9:08 pm

Batz wrote:
I need a holiday in Queensland :D :D


Your welcome here mate.
Pull up the van anytime.


It is on my list of plans mate....just got to sell the business and actually retire :lol:

:cheers:
The worst thing that can happen if I die is that my wife will sell all my brewing equipment for what I told her I paid for it
User avatar
Dicko
 
Posts: 1179
Joined: Tue Jan 21, 2014 8:25 pm
Location: Port Lincoln South Oz
Model: 20 litres

Re: I broke my pump impeller

Unread postby Dan » Sun Dec 28, 2014 9:08 pm

Dicko wrote:OK, so my impeller didn't arrive before Xmas and I wanted to brew yesterday so I used the broken impeller.

I had a grain bill of 6kg in the 20 BM and it worked without fault....no noise...no vibration...just clean clear wort.

I can't wait to taste my "Broken Impeller IPA" :lol: :lol:

:cheers:


Glad to hear all went well mate.
Now you have a reliable temporary back-up should you make the same mistake twice ..... but let's hope not
User avatar
Dan
 
Posts: 115
Joined: Wed Jan 22, 2014 12:39 pm
Location: Koppio - South Oz
Model: 20 litres

Re: I broke my pump impeller

Unread postby Dicko » Mon Dec 29, 2014 12:16 am

Dan wrote:
Dicko wrote:OK, so my impeller didn't arrive before Xmas and I wanted to brew yesterday so I used the broken impeller.

I had a grain bill of 6kg in the 20 BM and it worked without fault....no noise...no vibration...just clean clear wort.

I can't wait to taste my "Broken Impeller IPA" :lol: :lol:

:cheers:


Glad to hear all went well mate.
Now you have a reliable temporary back-up should you make the same mistake twice ..... but let's hope not


At $55 plus auspost I dont want to do that again Dan. :shock:

:cheers:
The worst thing that can happen if I die is that my wife will sell all my brewing equipment for what I told her I paid for it
User avatar
Dicko
 
Posts: 1179
Joined: Tue Jan 21, 2014 8:25 pm
Location: Port Lincoln South Oz
Model: 20 litres

Re: I broke my pump impeller

Unread postby Batz » Mon Dec 29, 2014 5:00 am

Did you find the broken vane Geoff? I'll have a go at gluing it back now you have a replacement.
Your not a real brewer until you own a Braumeister
User avatar
Batz
 
Posts: 313
Joined: Tue Jan 21, 2014 9:42 pm
Location: Queensland Australia
Model: 50 litres

Re: I broke my pump impeller

Unread postby Dicko » Mon Dec 29, 2014 10:31 am

Batz wrote:Did you find the broken vane Geoff? I'll have a go at gluing it back now you have a replacement.


Hi Jeff,

I did have the broken bit but because the G and G people said they were sending it immediately I have now misplaced it :roll:

I would have thought that the replacement may have been in the mail today..... it could be G and G not sending or just Australia Post at Xmas time being overloaded....hated to believe as I have never seen any one from that establishment ( Aus Post) ever exert themselves./ :lol:
I was reluctant to have a loose bit possibly working in my BM pump...hence the experiment with the impeller with the vane blade missing...I was a bit concerned about the glued on vane breaking

After the IPA I did a Bo Pils today and it all worked as planned with the dodgy impeller.....very happy... Not too worried as to when I actually receive the new impeller.

:cheers:

:cheers:
The worst thing that can happen if I die is that my wife will sell all my brewing equipment for what I told her I paid for it
User avatar
Dicko
 
Posts: 1179
Joined: Tue Jan 21, 2014 8:25 pm
Location: Port Lincoln South Oz
Model: 20 litres

Re: I broke my pump impeller

Unread postby kriaar » Mon Dec 29, 2014 8:36 pm

same thing happened to my impeller.. (only one piece broke off) No problem works just fine
kriaar
 
Posts: 2
Joined: Mon Dec 29, 2014 8:31 pm
Model: 50 litres

Previous

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests