Faulty pump

Experiencing technical problems? Look here for help!

Faulty pump

Unread postby Erkopale » Sat Aug 02, 2014 11:43 pm

Hey brewers,
I have a feeling the pump from my 20l brau has burnt out. I went to start ventilating this morning, it started then stopped. Took the pump off, nothing impeding the impeller, tried manual pump operation... No movement.
Will get in touch with my retailer tomorrow, but anybody with any thoughts in the interim?

I was looking forward to brewing this morning:(
Erkopale
 
Posts: 2
Joined: Fri Jan 24, 2014 6:57 am
Location: Sydney, Australia
Model: 20 litres

Re: Faulty pump

Unread postby niels » Sun Aug 03, 2014 9:18 pm

I don't know if it is a good idea, but can't you supply voltage directly to the pump? This way you know that it is not a controller issue.

Maybe a lose connection?

- Niels
User avatar
niels
Site Admin
 
Posts: 1054
Joined: Mon Dec 02, 2013 8:08 pm
Location: Belgium
Model: 50 litres

Re: Faulty pump

Unread postby Batz » Mon Aug 04, 2014 12:06 am

Give the pump plug a wiggle.

Batz
Your not a real brewer until you own a Braumeister
User avatar
Batz
 
Posts: 312
Joined: Tue Jan 21, 2014 9:42 pm
Location: Queensland Australia
Model: 50 litres

Re: Faulty pump

Unread postby Erkopale » Tue Aug 05, 2014 10:06 am

Got hold of the retailer, grain and grape, who had been onto Ralph. I am awaiting details but the word is the pump is being replaced. Have had the 20 l less than 12 months. Should be all good.
Erkopale
 
Posts: 2
Joined: Fri Jan 24, 2014 6:57 am
Location: Sydney, Australia
Model: 20 litres


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest